ITS Exchange Service
About the Exchange Service
Using Exchange
For IT Staff
Tech Docs
Requests
ITS Exchange Service

Clients Supported by Exchange 2010

Outlook Web App (OWA) - Full Features

To use the complete set of features available in Outlook Web App, the following browsers are recommended:

Windows 7, Vista, 2003, XP Max OS X Linux
  • Internet Explorer 7 and later
  • Firefox 3.0.1 and later
  • Chrome 3.0.195.27 and later
  • Safari 3.1 and later
  • Firefox 3.0.1 and later
  • Firefox 3.0.1 and later

Outlook Web App - Light Version

If you are using a Web browser that doesn't support the full feature set, you will automatically be directed to the light version of Outlook Web App. You may also want to use the light version if you are on a slow connection or using a computer with unusually strict browser security settings.

The light version of Outlook Web App:

Supported Clients

Windows Mac OS X Mobile Devices
  • Outlook 2010
  • Outlook 2007
  • General IMAP and POP clients

Outlook 2002/2003 are no longer supported. if you cannot avoid using Outlook 2003, see Modifying Outlook 2003 to Work with Exchange 2010.

  • Outlook for Mac 2011 (EWS [Exchange Web Services] version only)
  • Mail.app (EWS version only)
  • iCal.app (EWS version only)
  • General IMAP and POP clients

WebDAV is not supported. Find alternatives for any services depending on WebDAV.

Blackberry

  • v5 recommended
    (v4 minimum)

ActiveSync

For these platforms, we recommend the latest OS version:

  • iPhone
  • iPad & iPad2
  • Android
  • Windows Mobile
Also, see note below

ActiveSync mobile users: See Current Issues with Microsoft Exchange ActiveSync and Third Party Devices